<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>MLB amateur draft next up for former Notre Dame standout Niko Kavadas</title><meta property=og:title content="Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders"/><link rel=amphtml href=https://amp.ndinsider.com/amp/7885510002 /><meta property=article:author content="Tom Noie"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.ndinsider.com /><link rel=preconnect href=https://user.ndinsider.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.ndinsider.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.ndinsider.com/NNDI-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z31a796c26.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3a6ede81e.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-ac0dc3b6.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-9e946b2b.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-04455b51.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/5395d9c7-6d2f-4108-a190-9174c624362e/7c520135-439e-4497-bb41-1803fadfb783/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7939303002" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="Former Penn, ND standout Niko Kavadas now waits on MLB draft direction"/><meta property=og:description content="Former Penn, ND standout Niko Kavadas now waits on MLB draft direction"/><meta property=fb:pages content=563684463771681 /><meta property=fb:app_id content=1075159272997428 /><link rel=canonical href=https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/ /><meta property=og:url content=https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/ /><meta property=og:site_name content="Notre Dame Insider"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?crop=3599,2024,x0,y183&width=3200&height=1800&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1800 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?crop=3599,2024,x0,y183&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@ /><meta name=twitter:creator content=@ /><meta name=twitter:title content="Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders"/><meta name=twitter:description content="Former Penn, ND standout Niko Kavadas now waits on MLB draft direction"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol><symbol id=gnt_svg_ldquote viewBox="0 0 36 36"><path d="M16.8 22.85c0 2.05-.71 3.75-2.15 5.11A7.45 7.45 0 0 1 9.33 30c-2.27 0-4.15-.8-5.67-2.38-1.52-1.6-2.28-3.77-2.28-6.54 0-2.31.62-4.77 1.86-7.39A39.14 39.14 0 0 1 8.09 6h8.4l-2.77 4.35a35.99 35.99 0 0 0-3.16 6.19c1.8.15 3.29.78 4.47 1.88a5.76 5.76 0 0 1 1.77 4.43zm17.82 0c0 2.05-.72 3.75-2.16 5.11A7.45 7.45 0 0 1 27.14 30c-2.27 0-4.15-.8-5.67-2.38-1.52-1.6-2.27-3.77-2.27-6.54 0-2.31.61-4.77 1.85-7.39A39.14 39.14 0 0 1 25.9 6h8.4l-2.77 4.35a35.99 35.99 0 0 0-3.16 6.19c1.8.15 3.29.78 4.47 1.88a5.76 5.76 0 0 1 1.78 4.43z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Notre Dame Insider" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#12294B preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.6 67.8"><path fill=#CFB361 d="M0 54.5l5.5-.2-.1-41.1H0L.2 0l17.5 1.1 21.4 34-.1-20.3-4.8-.1-.3-13.1 59.6 3 10.4 8.1.6 40.1-10.4 8.3-36 2.7-.2-13.1 5-.2-.7-35.3-8.8-.5V64l-11.6.7-21.1-32.9v21.8h4v12.2L0 67.8V54.5zm76.9-4.2l9.5-.6 5.5-5.4-.3-25-5.3-3.8-9.9-.5.5 35.3z"/><path d="M135.2 25.2c-.1 3.9-.3 7.7-.4 11.5-.2 6.5-.5 13.1-.8 19.6 0 .6 0 .6-.6.7-3.1.3-6.3.5-9.5.8-.6.1-.6 0-.6-.5.3-9.4.7-18.8 1.1-28.2l.6-16.9c.1-1.5.1-2.9.2-4.4 0-.4.1-.5.5-.5l11 .6c.4 0 .5.3.6.5l6.8 16.1c2 4.8 4.1 9.6 6.1 14.3.1.2.2.5.4.6 0-.4.1-.8.1-1.2l.9-23.2c.1-1.9.1-3.8.2-5.8 0-.4 0-.5.5-.5 2.6.2 5.2.3 7.8.4.6 0 .6 0 .6.7-.3 5.6-.5 11.2-.8 16.8l-1.3 27.6c0 .6 0 .6-.7.7-2.7.2-5.4.5-8.1.7h-.4c-.5.1-.7-.1-.9-.5l-3.3-7.5c-3.2-7.4-6.4-14.8-9.7-22.1l-.3-.3zm54.3-1.2c-1.5-.1-2.9-.2-4.3-.2-.3 0-.4-.2-.4-.5-.2-1.4-1-2.6-2.1-3.4a6.04 6.04 0 00-5.8-.7c-1.2.4-2.1 1.5-2.2 2.8-.1 1.2.5 2.5 1.6 3.1.3.2.7.4 1.1.6 1.2.6 2.4 1.1 3.7 1.6 1.9.7 3.8 1.6 5.6 2.6 3.3 1.9 5.4 4.7 5.9 8.6.3 1.9.3 3.9-.1 5.8-.6 2.4-2.1 4.5-4.1 5.9-2.5 1.8-5.4 2.9-8.4 3.3-3.5.6-7.1.2-10.3-1.1-5.5-2.3-8.3-6.5-8.8-12.3 0-.5-.3-1.1 0-1.4s.9-.1 1.4 0l8.5.3c.4 0 .5.1.5.5-.1 2.4 1.5 4.5 3.8 5.1 1.9.6 3.9.6 5.9 0 .8-.2 1.5-.7 2.1-1.3 1.4-1.5 1.3-3.9-.2-5.2-.8-.8-1.7-1.3-2.7-1.6-1.5-.5-2.9-.9-4.4-1.3-2-.6-3.8-1.5-5.5-2.6-3.3-2.2-5.4-5.8-5.6-9.8-.1-1.5-.1-3 .3-4.5.7-2.8 2.5-5.2 5.1-6.7 5.7-3.2 12.7-3 18.2.7.2.1.3.2.5.3.8.4 1.2 1.2 1.1 2 0 .6.1 1.3.4 1.9.5 1.2.4 2.6-.2 3.7-.6 1.1-.7 2.5-.1 3.6-.6-.1-.6.1-.5.2zm25.2-12.3c2.6.1 4.9.3 7.4.4 1.7.1 3.4.3 5 .7 5 1.3 8 4.5 9.3 9.5.6 2.7.9 5.4.7 8.1-.1 3.6-.8 7.1-2.1 10.4-1.7 3.9-4.4 6.8-8.5 8.2-1.6.5-3.3.7-5 .8l-11.3.9h-.3c-.3 0-.4-.1-.4-.4.1-1.5.3-3 .4-4.5.3-3.9.7-7.8 1-11.7l.6-7.3c0-.3.2-.5.4-.5.6-.2 1.1-.5 1.6-.8 1.3-.8 1.9-2.3 1.6-3.8-.1-.4-.1-.7-.1-1-.2-1.2-.1-2.4.4-3.5.2-.6.5-1.2.7-1.9.4-1.2.1-2.6-.9-3.4l-.5-.2zm7.6 8.8h-1.8c-.8 0-.8 0-.8.8l-.9 10-.9 9.8c0 .3 0 .5.4.5 1.8.2 3.7.1 5.5-.2 2.1-.3 3.9-1.6 4.8-3.5.3-.5.5-1 .7-1.5.9-2.7 1.2-5.5 1-8.3-.1-1.8-.7-3.6-1.7-5.1a5.6 5.6 0 00-3.9-2.4c-.8 0-1.6-.1-2.4-.1zM109 33c.2-6.9.5-13.7.8-20.6.1-1.8.2-3.6.2-5.4 0-.5.2-.5.6-.5 2.7.2 5.5.3 8.2.5.6 0 1.2.1 1.8.1.4 0 .5.1.5.5-.4 8.3-.8 16.6-1.1 24.9l-.9 19.2-.3 6.1c0 .5-.2.6-.6.7-3.2.2-6.4.5-9.6.8-.4 0-.5 0-.5-.5.2-4.2.3-8.3.5-12.5l.3-9c0-1.4 0-2.9.1-4.3zm143.8-11.8h-5.5c-.5 0-.6.1-.7.6-.1 1.5-.3 2.9-.4 4.4-.1.6-.1.6.5.6h9.6c.4 0 1-.2 1.2.1s0 .8 0 1.2c-.1 1.6-.4 3.3-.5 5 0 .4-.2.5-.5.5-2.3 0-4.5.1-6.8.1-1.2 0-2.5.1-3.8.1-.3 0-.4.1-.5.5-.2 1.9-.3 3.9-.5 5.8 0 .4.1.5.4.5l5.6-.3 5.9-.3c.4 0 .5.1.4.5-.3 2-.5 4-.8 6-.1.8-.1.7-.8.8l-8.9.7c-2.9.2-5.7.5-8.6.7-.4 0-.5-.1-.5-.5l.6-6.4.9-9.9c.5-5.2.9-10.4 1.4-15.6.1-.9.2-1.7.2-2.6 0-.4.1-.5.6-.5l11 .6 6.6.3c.6 0 .6 0 .5.6l-.6 6.2c0 .5-.2.6-.6.6h-5.6l.2-.3zm22.5 10.3c1.1.7 1.8 1.9 1.9 3.1.1 1.2.2 2.3.1 3.5-.1 1.6-.1 3.2 0 4.8 0 .8.2 1.6.7 2.2l-2.9.2c-.6.1-1.2.1-1.9.2-.3 0-.4-.1-.5-.4-.2-1.7-.2-3.4-.1-5.2.1-1.1 0-2.2-.4-3.3-.4-1.4-1.7-2.3-3.1-2.2-.8 0-1.6.1-2.4 0-.4 0-.5.1-.6.5l-.9 8.2c-.1.8-.2 1.6-.2 2.5 0 .4-.2.5-.5.5-1.6.1-3.1.2-4.7.4-.5 0-.4-.2-.4-.5.3-3.1.6-6.1 1-9.2.3-3.2.7-6.5 1-9.7.4-4.3.9-8.5 1.3-12.7.1-.7.1-.7.8-.7 3 .2 6 .2 9 .5 1 .1 2 .3 2.9.7 2.1.8 3.6 2.8 3.9 5.1.4 2.6.1 5.2-.8 7.7-.6 2.1-1.4 2.9-3.2 3.8zm-6.2-3c.5-.1 1.1-.1 1.6-.1 2.1-.1 3.3-1.1 3.7-3.2.1-.3.1-.7.1-1 .1-2.1-1-3.3-3.1-3.5-1-.1-2.1 0-3.2 0-.4 0-.5.1-.5.5-.2 2.3-.5 4.6-.7 6.9 0 .4.1.4.4.4h1.7zm-67.3.1h3.9c.4 0 .6 0 .5.5-.6 6.1-1.1 12.3-1.6 18.4l-.3 3c0 .4-.2.5-.5.5-2.7.2-5.3.5-8 .7-.5 0-.5 0-.5-.5l1.5-16.3c.2-1.8.3-3.7.5-5.6 0-.5.2-.6.7-.6h3.9l-.1-.1zM282.7 45a2 2 0 01-2-2v-.1c0-1.1 1-1.9 2.1-1.9s2 .9 1.9 2v.1c0 1.1-.9 1.9-2 1.9zm1-1c.4 0 .4-.4.5-.6.2-.7-.2-1.5-.8-1.8-.6-.3-1.3-.1-1.7.4-.4.6-.4 1.4 0 2 .5.5 1.2.7 1.8.3.1 0 .3-.1.2-.3z M283.8 44c-.3.1-.6 0-.6-.4 0-.2-.2-.3-.4-.3-.3 0-.2.2-.2.4s0 .4-.2.3c-.3 0-.2-.2-.2-.4v-1.2c0-.3.1-.4.4-.4h.8c.3.1.6.4.4.6-.3.4-.1.6 0 .9-.1.2-.1.3 0 .5zm-1-1.6c-.2 0-.2.1-.2.3s.1.3.3.2.3-.1.3-.2-.3-.3-.4-.3zM16.4 3.4l25.1 40-.1-30.7-4.9-.1-.2-8.6 20 1-.3 7.4h-4.9v49.4l-8 .5-24.7-38.4V56h4v7.8l-20 1.5v-8.5l5.5-.2-.2-45.7H2.4l.2-8.4 13.8.9zm43.6 2v7.4l4.6.1.8 39.8-5 .2.2 8.4 32.8-2.4 9-7.2-.6-37.8-9-7L60 5.4zm27 7.9l6.8 4.9.3 27.2-6.8 6.6-12.8.8-.5-40.1 13 .6z"/><path fill=#364260 d="M56 12.4l.3-7.4-20-1 .2 8.5 4.9.1V40c3.3-.1 6.5-.3 9.7-.7v-27H56zm36.7-5.5L60 5.4v7.4l4.6.1.4 24.2c3.2-.7 6.3-1.5 9.3-2.5l-.3-22 13 .7 6.8 4.9.1 8c2.7-1.5 5.3-3.2 7.8-5.1l-.1-7.2-8.9-7zM39.3 40.1l-23-36.7-13.8-.9-.2 8.4h5.3l.1 26c3.4.8 6.9 1.4 10.6 2v-15l10.3 15.9c2.7.2 5.5.2 8.3.2.8.1 1.6.1 2.4.1z"/><path d="M36.3 5.3l19 .8-.2 6.3h.9l.3-7.5-20-.9zm64.3 9.8l.1 6.8 1-.7-.1-7.2-9-7L60 5.4v1.2l31.7 1.5 8.9 7zM16.4 3.4L2.5 2.5v1.3l12.8.9 22.2 35.5h1.8L16.4 3.4z"/><path fill=#0BA64F d="M209.7 13.8s.1-.1 0 0c.2 0 .2 0 .3-.1.4-.2.8-.4 1.2-.5.9-.3 1.9.1 2.2 1.1.1.3.1.6.1.9 0 .4-.1.8-.3 1.2-.2.5-.4.9-.5 1.4-.9 2.1-.8 1.9-.2 3.6.5 1.1.1 2.5-1 3.1-1 .9-2.4 1-3.5.2-1.1-.7-2-1.7-2.6-2.9-.1-.2-.3-.4-.5-.6v5c0 .4-.1.6-.5.6h-3.6c-.1-.2 0-.3.1-.4.6-1.1 1.2-2.3 1.7-3.5.2-.5.4-1 .4-1.6 0-.5-.2-.6-.6-.4-.4.2-.8.5-1.1.9-.8.9-1.8 1.8-2.8 2.5-.8.5-1.7.9-2.7 1.1-2 .3-4.3-1.3-4.5-3.2-.1-1.1.3-2.3 1-3.2.6-.7.7-1.6.4-2.4l-.6-1.8c-.5-1.6-.1-3.3 1.2-4.4.8 1.3 1.9 2.4 3.1 3.3 1.8 1.4 4.1 2.2 6.4 2.2 1.7 0 3.4-.4 5-1 .8-.3 1.4-.7 1.9-1.1z"/><path fill=#5CB26A d="M209.7 13.8c-.5.5-1.2.8-1.9 1-1.6.6-3.3 1-5 1-2.3 0-4.6-.7-6.4-2.2-1.2-.9-2.2-2-3.1-3.3 1.2-1.3 2.5-1.4 3.8-.2.5.4.9.9 1.4 1.3s.8.5 1.2.3c.4-.3.6-.8.4-1.3-.4-1.1-.7-2.3-.8-3.5-.1-2.5 1.4-3.7 3.4-3.9.7-.1 1.3.2 1.7.8.5.8 1.5 1.3 2.5 1 2.4-.4 4.5 2.4 3.7 4.9-.3.8-.6 1.6-1.1 2.3-.1.2-.2.4-.4.7-.3.7-.2.9.6 1.1zm.3-.1c0 .1-.1.1-.2.1 0-.1.1-.2.2-.1z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.ndinsider.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$9.99 per month" elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.ndinsider.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$9.99 per month" elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/football/ data-t-l=:n|v|c|football elementtiming=nav-item>Football</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/recruiting/ data-t-l=:n|v|c|recruiting>Recruiting</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/irish-stew/ data-t-l=:n|v|c|irish-stew>Irish Stew</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/basketball/mens/ data-t-l=:n|v|c|mens-basketball>Men's Basketball</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/basketball/womens/ data-t-l=:n|v|c|womens-basketball>Women's Basketball</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/more-sports/ data-t-l=:n|v|c|more-sports>More Sports</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.ndinsider.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.ndinsider.com/NNDI-GUP/authenticate?success-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&cancel-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-in-southbend-ndinsider-C6624-high_impact-sports-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Sports data-c-ssts=SPORTS></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders</h1><div class=gnt_ar_by><a href=https://www.southbendtribune.com/staff/4180693001/tom-noie/ class="gnt_ar_by_a gnt_ar_by_a__fi">Tom Noie</a><div class=gnt_ar_pb>ND Insider</div></div><div class=gnt_ar_dt aria-label="Published 3:01 p.m. ET Jul. 11, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/ data-ss-t="Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders" data-ss-d="Former Penn, ND standout Niko Kavadas now waits on MLB draft direction"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1075159272997428&href=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&text=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders%20-%20from%20Notre%20Dame%20Insider&body=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders%0A%0AFormer%20Penn%2C%20ND%20standout%20Niko%20Kavadas%20now%20waits%20on%20MLB%20draft%20direction%0A%0ACheck%20out%20this%20story%20on%20ndinsider.com%3A%20https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - Triple amputee slays on waves and on the slopes"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;in-southbend-ndinsider-C6624&#34;,&#34;pn&#34;:&#34;Notre Dame Insider&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;sports/sportskind&#34;,&#34;byline&#34;:&#34;Sportskind&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-07-12T16:47:52Z&#34;,&#34;credit&#34;:&#34;Sportskind, USA TODAY&#34;,&#34;duration&#34;:47000,&#34;headline&#34;:&#34;Triple amputee slays on waves and on the slopes&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/5395d9c7-6d2f-4108-a190-9174c624362e/7c520135-439e-4497-bb41-1803fadfb783/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7939303002&#34;,&#34;id&#34;:&#34;7939303002&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/07/12/USAT/0fe32eaa-d57e-442a-97d2-5f7cef20845d-SWNS_Triple_amputee_athlete_16x9_Thumbnail_1.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-07-12T16:47:52Z&#34;,&#34;keywords&#34;:&#34;Extreme sports,Overall Positive,Video Syndication - USAT,Video Syndication – International&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/5395d9c7-6d2f-4108-a190-9174c624362e/7c520135-439e-4497-bb41-1803fadfb783/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/sports/sportskind/2021/07/12/triple-amputee-slays-waves-and-slopes/7939303002/&#34;},&#34;promoBrief&#34;:&#34;When Cameron Clapp lost three limbs 20 years ago, doctors told him he'd never walk again. Now, he can surf, snowboard, and drive.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-07-12T16:49:23Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;sports&#34;,&#34;subsection&#34;:&#34;sportskind&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;46a7bed5-ecc7-4aab-afe1-e2d6081ead7f&#34;,&#34;name&#34;:&#34;Extreme sports&#34;},{&#34;id&#34;:&#34;7095bb07-b172-434b-a4eb-8856263ad949&#34;,&#34;name&#34;:&#34;Overall Positive&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;abb1b69c-143a-47e0-9004-50120aa6b80d&#34;,&#34;name&#34;:&#34;Video Syndication – International&#34;}],&#34;title&#34;:&#34;Triple amputee slays on waves and on the slopes&#34;,&#34;url&#34;:&#34;/videos/sports/sportskind/2021/07/12/triple-amputee-slays-waves-and-slopes/7939303002/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/07/12/USAT/0fe32eaa-d57e-442a-97d2-5f7cef20845d-SWNS_Triple_amputee_athlete_16x9_Thumbnail_1.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Triple amputee slays on waves and on the slopes" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><div class="gnt_em gnt_em__fp gnt_em_pq" data-c-cr="NOTRE DAME FIRST BASEMAN NIKO KAVADAS ON HIS MLB DRAFT OUTLOOK" data-c-pq="“If a great opportunity presents itself here in the next few days, that’s an avenue that I’ll pursue. But if a great opportunity doesn’t present itself, I’m lucky enough to have the option to go back to college and compete for a national championship at Notre Dame.”"><svg class=gnt_em_pq_svg><use xlink:href=#gnt_svg_ldquote /></svg></div><p class=gnt_ar_b_p>When it all gets too confusing, and thoughts about what the next few days might bring get too cluttered, Notre Dame first baseman Niko Kavadas knows where and how to find clarity in everything.</p><p class=gnt_ar_b_p>That would be on the golf course, where chasing a ball down the fairways and across the greens of Knollwood Country Club near his Granger home allows Kavadas to stop thinking about his future of hitting one with a bat.</p><p class=gnt_ar_b_p>Eighteen holes with younger brother C.J. and everything in the Kavadas world is all right. He usually only plays on days that end in ‘y.’</p><p class=gnt_ar_b_p>“Sounds kind of nice, doesn’t it?” Kavadas said by phone last week. “It’s a lot going on right now, but golf keeps your mind off it. There’s just a lot of uncertainty, man. I don’t know where I’ll be in two weeks.”</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:443px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9b62b2f0-cbe5-4610-a534-8b4b322a37d5-niko1.jpg?width=660&height=443&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9b62b2f0-cbe5-4610-a534-8b4b322a37d5-niko1.jpg?width=1320&height=886&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Following a record-setting, dream season at Notre Dame, former Penn High School standout Niko Kavadas now waits word on the MLB draft, which starts Sunday."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Following a record-setting, dream season at Notre Dame, former Penn High School standout Niko Kavadas now waits word on the MLB draft, which starts Sunday." data-c-credit="Tribune Photo/MICHAEL CATERINA, South Bend Tribune"></div></figure><p class=gnt_ar_b_p>How about two days? On Sunday, the annual Major League Baseball amateur draft commences in Denver. The draft runs three days. Somewhere along the course of it — Monday's the target day — the 6-foot-1, 235-pound former Penn High School standout will hear his cell phone ring. He might not recognize the number, but will know that a representative from a major league team will be on the other end with news that said team has selected Kavadas somewhere — likely somewhere early — in the 20-round process.</p><p class=gnt_ar_b_p>That’s when it will get interesting for Kavadas.</p><p class=gnt_ar_b_p>This should be the best time in the 22-year-old’s life. In May, Kavadas graduated with a business degree from his dream school, located barely seven miles from the family home. In June, the two-time team captain was the talk of the college baseball world, hitting home runs nearly every time he stepped to the plate in leading a Notre Dame team that many figured would finish last in the Atlantic Coast Conference to within one win of its first College World Series appearance since 2002.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>There arguably was no better story in college baseball this spring than Notre Dame. Nobody knew about the Irish. Nobody cared about the Irish. Under second-year coach Link Jarrett, the Irish were ranked as high as No. 2 and ran away with the ACC regular-season championship. They won 34 games, won 16 road games — the program’s most in 28 years — and were scary good as host of an NCAA tournament regional. Notre Dame nearly beat eventual national champion Mississippi State in the super regional.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Along the way, the Irish coined themselves “Team Nyquil.” It was a season-long running joke in the clubhouse.</p><p class=gnt_ar_b_p>“Everyone was sleeping on us,” Kavadas said. “It was something that we rallied behind and something that motivated us.”</p><p class=gnt_ar_b_p>Motivated them nearly all the way to Omaha, Nebraska. Along the way, Kavadas set a school record for home runs (22) in a season. He drove in 64 runs and hit .302. He became the first Irish to earn two separate first team postseason All-American honors since Steve Stanley in 2002.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Pro baseball seemingly is the logical next step for Kavadas, who first dreamed of being in the show when he was a high school freshman. He looked around the Penn baseball field and told himself, ‘I can do this.’ He’d go to Notre Dame baseball games, look around Eck Stadium and tell himself, ‘I can’t wait to do that.’ He’d watch MLB games on TV and think, ‘One day, I’ll do that.’</p><p class=gnt_ar_b_p>That one day is now. Or is it?</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="First baseman Niko Kavadas couldn't have dreamed a more perfect scenario than his senior season at Notre Dame, which ended with the Irish winning 34 games."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="First baseman Niko Kavadas couldn't have dreamed a more perfect scenario than his senior season at Notre Dame, which ended with the Irish winning 34 games." data-c-credit="John Mersits, South Bend Tribune"></div></figure><h2 class=gnt_ar_b_h2>A remarkable run</h2><p class=gnt_ar_b_p>Would Kavadas ponder putting pro ball on hold for one more year and return to Notre Dame for his super senior season (an option thanks to the global pandemic) to make one more run with the Irish?</p><p class=gnt_ar_b_p>Really?</p><p class=gnt_ar_b_p>“Absolutely,” Kavadas said. “It’s always been a dream of mine to play professional baseball, but it’s also been a dream of mine to play in Omaha and win a national championship. To do that at a school that’s right in my backyard and a place that I’ve loved my entire life, it would be kind of crazy not to think about going back.”</p><p class=gnt_ar_b_p>Want more crazy? Kavadas can’t fathom — at least today — telling his Irish teammates and the coaching staff that he’s a former Irish. That his days of terrorizing ACC pitching at Eck Stadium are over. Maybe they are. But maybe...</p><p class=gnt_ar_b_p>“To say that these guys that I’ve loved playing with four years and these coaches I’ve developed incredible relationships with are going to be former coaches and former teammates, that would be really difficult,” Kavadas said.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>For now, Kavadas is thinking only pro ball. When the pandemic turned everything upside down last year, MLB sliced the summer draft to five rounds. There was an outside shot that Kavadas, whose junior year was limited to seven home runs, 17 RBIs, and a .255 batting average in 13 games, would sneak into the final round. A few teams called to inquire, but offered little financial incentive. When he wasn't selected, that wasn’t necessarily bad news for him, or for the Irish.</p><p class=gnt_ar_b_p>“It was tremendous motivation,” Kavadas said. “I was disappointed and frustrated.”</p><p class=gnt_ar_b_p>Teammate Jared Miller counseled Kavadas to channel that disappointment and frustration in the right ways. Miller told Kavadas to look at being bypassed not as an opportunity missed to play pro ball, but an opportunity gained to play at least another year of college. So make the most of it.</p><p class=gnt_ar_b_p>Even as early as last summer — and even late last spring — the Irish believed they had a chance to be special. Along the way, Kavadas had a chance to show scouts that they made a mistake by dismissing him.</p><p class=gnt_ar_b_p>“The minute I started looking at it that way, that’s when the chip on the shoulder grew a little bit,” Kavadas said. “It led to a really, really productive and a really, really fun season.”</p><p class=gnt_ar_b_p>A season that for all the ups, ended with the worst of downs – that Game Three super regional loss at Mississippi State on June 14. In his second-to-last at-bat, Kavadas hammered a home run to right field that only recently stopped rolling. In his last at-bat, he grounded into a game- and season-ending double play.</p><p class=gnt_ar_b_p>Then, nothing but silence.</p><p class=gnt_ar_b_p>“I don’t think anyone said a word from the time the last out was made to the time Coach Jarrett gave his post-game meeting back in the hotel,” Kavadas said. “No one could believe that the run we were on came to an end.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>“We really thought we were the best team in the country. There was no doubt in our minds that we were going to Omaha.”</p><p class=gnt_ar_b_p>Instead, the Irish went their separate ways. Kavadas took about a week and a half to let his body and his mind heal. It had been a whirlwind run and that wore him out. He and the Irish both went from unknowns to knowns. Everyone knew Kavadas’ name at season’s end, but he’d trade all that to have extended the season another few weeks.</p><p class=gnt_ar_b_p>“All the accolades and attention were cool, but the thing I’m most proud of is the fact that Jared Miller and I are designing ACC championship rings right now,” Kavadas said. “Not a whole lot of people thought that was possible. That’s probably the coolest thing we accomplished this year.”</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/f83e93d4-633f-48b0-b576-ced80052c7bc-niko3.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/07/NNDI/f83e93d4-633f-48b0-b576-ced80052c7bc-niko3.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="First baseman Niko Kavadas looks to be the first top-five round draft pick for Notre Dame since 2018."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="First baseman Niko Kavadas looks to be the first top-five round draft pick for Notre Dame since 2018." data-c-credit="John Mersits, South Bend Tribune"></div></figure><h2 class=gnt_ar_b_h2>A lot to offer, and options</h2><p class=gnt_ar_b_p>Asked for his take on what his MLB draft profile might say, Kavadas points to his offensive production. In 161 career games, he hit 46 home runs with 144 RBIs and a .286 career average. He can hit for power to all parts of the park. He can dissect right-handers and left-handers with equal effectiveness. He’s got as lively a swing from the left side as anyone.</p><p class=gnt_ar_b_p>“I’ll give you a competitive at-bat and find a way to leave the yard a couple times a week and help the team win,” he said.</p><p class=gnt_ar_b_p>Kavadas believes his discipline and self-awareness already are MLB ready. He shook a late-season slump when he "didn't know what end of the bat to hold" to catch summer afternoon hot for the NCAA tournament run. In six NCAA games, Kavadas smacked six home runs with 15 RBIs. On the game's biggest stage, he delivered big at-bats.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Like in the first NCAA game against Central Michigan. Dropped to sixth in the batting order after his previous struggles. Kavadas refused to pout. He instead relaxed, then responded with four RBIs and two home runs.</p><p class=gnt_ar_b_p>"Those balls were annihilated," Jarrett said after a 10-0 win. "He had been pressing a little bit and when you're pressing, it's not fun."</p><p class=gnt_ar_b_p>Weakness? That’s easy. Kavadas is kind of, sort of pigeon-holed as a limited defensive player as a first baseman. In this baseball age of versatility — guys who play in the bigs better play multiple positions — Kavadas is either a first baseman or a designated hitter. That’s it.</p><p class=gnt_ar_b_p>“Not necessarily my claim to fame,” he admits.</p><p class=gnt_ar_b_p>Still, there’s a place for him somewhere in the game. Ranked by mlb.com as the No. 136 prospect would slot Kavadas as a late fourth-round or somewhere in the fifth round selection. That means Monday might be a life-changing day. The second round starts at 1 p.m. Maybe by dinner at his parents’ home, Kavadas will get <em>the</em> call.</p><p class=gnt_ar_b_p>Then comes the decision — start pro ball or finish next spring what Kavadas and the Irish started this one?</p><p class=gnt_ar_b_p>“If a great opportunity presents itself here in the next few days, that’s an avenue that I’ll pursue,” he said. “But if a great opportunity doesn’t present itself, I’m lucky enough to have the option to go back to college and compete for a national championship at Notre Dame.”</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-native-article_link-sports-7 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Asked to define great opportunity, Kavadas paused, like he was trying to read a putt up at Knollwood, or waiting at the plate on a fastball.</p><p class=gnt_ar_b_p>“I’ll know it,” he said, “when I see it.”</p><p class=gnt_ar_b_p><em>Follow South Bend Tribune and NDInsider columnist Tom Noie on Twitter: @tnoieNDI</em></p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/ data-ss-t="Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders" data-ss-d="Former Penn, ND standout Niko Kavadas now waits on MLB draft direction"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=1075159272997428&href=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&text=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders%20-%20from%20Notre%20Dame%20Insider&body=Noie%3A%20After%20a%20serious%20spring%2C%20Notre%20Dame%201B%20Niko%20Kavadas%20waits%20and%20wonders%0A%0AFormer%20Penn%2C%20ND%20standout%20Niko%20Kavadas%20now%20waits%20on%20MLB%20draft%20direction%0A%0ACheck%20out%20this%20story%20on%20ndinsider.com%3A%20https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-in-southbend-ndinsider-C6624-poster-sports-8 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.ndinsider.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&marketName=ndinsider&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|We're always working..." aria-label="We're always working to improve your experience. Let us know what you think."></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-in-southbend-ndinsider-C6624-poster_scroll-sports-9 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><aside class=gnt_pm onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-u-sr="anon reg" aria-label="free articles left. - Summer Sale! $9.99 per month" data-g-r=base_ex><button class=gnt_pm_eb data-g-r=base_et aria-expanded=false aria-label="Special offer"></button><div class="gnt_pm_ms gnt_pm__de"></div><a class="gnt_pm_a gnt_pm__de" href="https://subscribe.ndinsider.com/?return-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&cancel-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&success-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&itm_medium=ONSITE&gps-source=CPCAMBARD&itm_source=CPCAMBARD&itm_content=freearticlesleft&itm_campaign=2021SUMMERFUN" aria-label="Subscribe Now" tabindex=0></a></aside><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-in-southbend-ndinsider-C6624-leaderboard_btf-sports-10 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Notre Dame Insider - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.ndinsider.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.ndinsider.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=http://www.indianapublicnotices.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.ndinsider.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.ndinsider.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.ndinsider.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.ndinsider.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.ndinsider.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/indiana/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.ndinsider.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.ndinsider.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.ndinsider.com/subscriberguide class=gnt_ft_a data-t-l=:f|v|c|support:subscriber-guide>Subscriber Guide</a> <a href=https://account.ndinsider.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.ndinsider.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=http://subscribe.ndinsider.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.ndinsider.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/notredameinsider class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://www.youtube.com/channel/UCAMR05qSc5mfhVx20fDyAoQ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:youtube>YouTube</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.ndinsider.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3a6ede81e.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.ndinsider.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.ndinsider.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.ndinsider.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.ndinsider.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.ndinsider.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.ndinsider.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.ndinsider.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.ndinsider.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.ndinsider.com/NNDI-GUP/user/logout/?return-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.ndinsider.com/NNDI-GUP/authenticate?success-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F&cancel-url=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.ndinsider.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.ndinsider.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><script type="gnt/tmpl" data-tmpl-key=vdscta><div class=gnt_em_vp_sbcta><a class=gnt_em_vp_sbcta_sb data-t-l=":d|d|auto subscribe|${t}" target=_blank rel=noopener href="https://subscribe.ndinsider.com/specialoffer?gps-source=IUXPLAYEROVERLAY&itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp&onSuccessRedirectURL=https%3A%2F%2Fwww.ndinsider.com%2Fstory%2Fsports%2F2021%2F07%2F11%2Fmlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas%2F7885510002%2F">Subscribe</a> <a class=gnt_em_vp_sbcta_dt data-t-l=":d|d|auto included|${t}" target=_blank rel=noopener href="https://cm.ndinsider.com/whats-included-subscribe?itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp">What's included?</a></div>|styles|.gnt_em_vp_sbcta{display:flex;flex-direction:column;text-align:center;position:absolute;top:25px;z-index:4;width:400px;height:225px;background:#000;color:#fff;font-family:'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;-webkit-user-select:none;user-select:none}.gnt_em_vp_sbcta::before{content:'Autoplay videos can be distracting. Make them go away.';order:-1;margin:38px 0 0;padding:0 55px;font-size:16px;line-height:20px;font-weight:700}.gnt_em_vp_sbcta::after{content:'Subscribers can turn off autoplay video - and more!';order:-1;margin:6px 0 12px;padding:0 88px;font-size:14px;line-height:16px}.gnt_em_vp_sbcta_sb{width:88px;height:30px;margin:0 156px 9px;border-radius:2px;background:#fff;color:#1665cf;font:700 14px/30px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;text-decoration:none;text-align:center}.gnt_em_vp_sbcta_sb:hover{color:#0a32a0}.gnt_em_vp_sbcta_dt{width:max-content;margin:0 auto;padding:0 2px;outline-offset:1px;color:#fff;font:12px/14px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_em_vp_sbcta_dt:hover{color:#e0e0e0}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3UC2guH6juZvHv5c76ZqpJKRcvw.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"Noie: After a serious spring, Notre Dame 1B Niko Kavadas waits and wonders","description":"Former Penn, ND standout Niko Kavadas now waits on MLB draft direction","url":"https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.ndinsider.com/story/sports/2021/07/11/mlb-amateur-draft-next-up-former-notre-dame-standout-niko-kavadas/7885510002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?crop=2400,2400,x900,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg?crop=3599,2024,x0,y183&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-07-11T19:01:33Z","dateCreated":"2021-07-11T19:01:33Z","dateModified":"2021-07-11T19:01:33Z","articleSection":"sports","publisher":{"@type":"Organization","name":"ND Insider","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/ndinsider/images/site-nav-logo@2x.png"}},"author":["Tom Noie"],"keywords":["access:metered","ssts:sports","type:story","tag:Notre Dame Fighting Irish","tag:Overall Neutral","tag:NCAA Atlantic Coast Conference","tag:MLB","tag:College Baseball","tag:National Sports"],"isAccessibleForFree":false,"hasPart":{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".gnt_ar_b"},"isPartOf":{"@type":["CreativeWork","Product"],"name":"ND Insider - Unlimited Digital Access","productID":"ndinsider.com:standard"},"metadata":"{\"id\":\"7885510002\",\"siteCode\":\"NNDI\",\"contentSourceCode\":\"NNDI\",\"ssts\":\"sports\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9b62b2f0-cbe5-4610-a534-8b4b322a37d5-niko1.jpg","caption":"Following a record-setting, dream season at Notre Dame, former Penn High School standout Niko Kavadas now waits word on the MLB draft, which starts Sunday.","copyrightHolder":"Tribune Photo/MICHAEL CATERINA, South Bend Tribune"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/07/NNDI/9a81739a-d0b3-481b-ac66-54c0b5399da9-niko2.jpg","caption":"First baseman Niko Kavadas couldn't have dreamed a more perfect scenario than his senior season at Notre Dame, which ended with the Irish winning 34 games.","copyrightHolder":"John Mersits, South Bend Tribune"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/07/NNDI/f83e93d4-633f-48b0-b576-ced80052c7bc-niko3.jpg","caption":"First baseman Niko Kavadas looks to be the first top-five round draft pick for Notre Dame since 2018.","copyrightHolder":"John Mersits, South Bend Tribune"}]</script></body></html>